Ubuntu 18.04 安装 Parallels Tools

利用 Parallels Desktop 14 安装 Ubuntu 18.04 ,在安装 Parallels Tools 时遇到安装错误,在网上搜索得知 Parallels Tools 不支持 Linux 内核版本大于 4.15 的系统。经过测试有一下3种解决方法:

方法 1 : 卸载自带的 Linux 内核,更换 Ubuntu 16.04 使用的内核(推荐

执行代码 sudo apt-get update && sudo apt-get dist-upgrade ,接着执行 sudo apt-get install linux-generic-hwe-16.04 ,可能会安装 Linux 5.0 ,执行内核卸载,重复执行 sudo apt-get install linux-generic-hwe-16.04 ,更新开机引导内核。

方法 2 : 手动安装 Linux 4.14 版本(成功,但不推荐)

打开这个网址,选择最新的 Linux 4.14.* ,下载对应系统的内核(64位),要下载4个文件: linux-headers-4.14.149-0414149_4.14.149-0414149.201910111332_all.deb,linux-headers-4.14.149-0414149-generic_4.14.149-0414149.201910111332_amd64.deb,linux-image-unsigned-4.14.149-0414149-generic_4.14.149-0414149.201910111332_amd64.deb,linux-modules-4.14.149-0414149-generic_4.14.149-0414149.201910111332_amd64.deb,在同级目录下,打开终端,执行安装内核命令 sudo dpkg -i *.deb ,删去正在使用的内核,更新开机内核。体验: 可以安装 Parallels Tools ,但每次开关机都要等3分钟,并且内核需要手动更新。

方法 3 : 自己修改 Parallels Tools 文件安装(失败)

按照网上教程,修改 Parallels Tools 文件,重新安装之后还是报错,可能没有修改对。

参考

使用标准方式在 Ubuntu 16.04 下启用 TCP 拥塞控制之 BBR

如何降级/切换 Ubuntu 系统 Linux 内核启动版本

Installing Parallels Tools on Ubuntu 18.04